Quartus Il Design Flow: Basic Steps Summary

1. Required Files

$ pwd
/Users/talarico/VTut
$ 1s -1

light.csv

light.v

light_tb.v

# File: light.csv (comma separated values)
# Pin Assignments

To, Direction, Location
x1, input, PIN_AB28

x2, input, PIN_AC28

f, output, PIN_E21

/*
File: light.v

Simple Tutorial to demonstrate the Verilog based design flow

with Altera/Modelsim.
The code implements a 2-input exor gate
*/

module light(x1,x2,f);

input x1,x2;

output f;

assign f = (x1 & ~x2) | (~x1 & x2);

endmodule

Page 1 of 19


1


// File: light_tb.v
// Test Bench for the light module
// author: Claudio Talarico

“timescale 1ns / 1ns
module light_tb;

// inputs to device under test (DUT — i.e. RTL Hardware)
reg ain;

reg bin;

//outputs from DUT

wire cout;

// instantiate the DUT
light dut(

.x1( ain ),

.x2( bin ),

.f( cout )
);

// output the simulation in graphical format
initial
begin
$dumpfile("light.vcd");
$dumpvars(0, dut);
end

//initialize inputs to DUT

initial
begin
ain = 0;
bin = 0;
end

// generate ain values (ain test vectors)
always

begin

# 20 ain = ~ain;

end

// generate bin values (bin test vectors)
always

begin

# 40 bin = ~bin;

end

// output the simulation in textual format
initial
begin
$monitor("At time %t, X1 is = %b, X2 is %b, F is %b",
$time, ain, bin, cout);
end
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// stop the simulation from running forever

initial
begin
# 200 $stop;
end
endmodule

2. Create Project

A project consists of:

* Project Name and Directory

* Name of the top-level design module
* Project Files and Libraries

* Target Device Family and Device

* EDA Tool Setting

File > New Project Wizard

Step 1.

G New Project Wizard

Directory, Name, Top-Level Entity

What is the WOWW for this project?

Upper case T

IZ:\Users\tala \VTut S

What is the name of this project?

design file.

What is the name e top-level design entity for this project? This name is case sensitive and must exactly match the entity name in the

lighd N

Use Existing Project Settings... \

Lower case t

< Back Next >p. Finish Cancel Help

I

\
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Step 2.

(O New Project Wizard

Project Type

Select the type of project to create.

@® Empty project
Create new project by specifying project files and libraries, target device family and device, and EDA tool settings.
O Project template

Create a project from an existing design template. You can choose from design templates installed with the Quartus Prime software, or
download design templates from the Design Store.

| <gack | [ Next>p| | Finish || cancel || Help |
\
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Step 3.

(O New Project Wizard X
Add Files
Select the design files you want to include in the project. Click Add All to add all design files in the project directory to the project.
Note: you can always add design files to the project later.
File name: I |B Add
« X
File Name Library Design Entry/Synthesis Tool HDL Version Remoe
: : Default
Default Up
Down
Properties
Specify the path names of any non-default libraries. |User Libraries...
l<BackHNek>H Finish HCancelH Help ‘
\

To modify a project use:
Project > Add/Remove Files in Project

To edit a new Verilog File with Quartus Text Editor use:
File > New > (Design Files > Verilog File)
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Step 4.

b New Project Wizard X
Family, Device & Board Settings

Device Board

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

To determine the version of the Quartus Prime software in which your target device is supported, refer to the Device Support List webpage.

Device family Show in ‘Available devices' list
Family: »Cyclone IVE A Package: Any v
Device: |All - Pin count: vAny 7 '
Target device Core speed grade: vAny hd
O Auto device selected by the Fitter Name filter:
@® Specific device selected in ‘Available devices' list Show advanced devices
Other: n/a

Available devices:

Name Core Voltage LEs Total 1/Os GPIOs Memory Bits Embedded multiplier 9-bit el L
EP4CE75F23C8L 1.0V 75408 293 293 2810880 400 4
EP4CE75F23C9L 1.0V 75408 293 293 2810880 400 4
EP4CE75F2317 1.2v 75408 293 293 2810880 400 4
EP4CE75F23I18L 1.0V 75408 293 293 2810880 400 4
EP4CE75F29C6 1.2V 75408 427 427 2810880 400 4
EP4CE75F29C7 1.2v 75408 427 427 2810880 400 4
EP4CE75F29C8 1.2v 75408 427 427 2810880 400 4
EP4CE75F29C8L 1.0V 75408 427 427 2810880 400 4
EP4CE75F29COL 1.0V 75408 427 427 2810880 400 4
EP4CE75F2917 1.2v 75408 427 427 2810880 400 4
EP4CE75F29I18L 1.0V 75408 427 427 2810880 400 4
EP4CE75U1917 1.2v 75408 293 293 2810880 400 4
EP4CE115F23C7 1.2V 114480 281 281 3981312 532 4
EP4CE115F23C8 1.2V 114480 281 281 3981312 532 4
EP4CE115F23C8L 1.0V 114480 281 281 3981312 532 4
EP4CE115F23C9L 1.0V 114480 281 281 3981312 532 4
EP4CE115F2317 1.2V 114480 281 281 3981312 532 4
EP4CE115F2318L 1.0V 114480 3981312 4
_-_
EP4CE115F29C8 1.2V 114480 529 529 3981312 4
EP4CE115F29C8L 1.0V 114480 529 529 3981312 532 4 .
< il T T T T >

< Back | Nextkl Finish ‘ Cancel Help

\

Family: Cyclone IV E
Device: EP4CE115F29C7
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To modify the FPGA family or the specific device use:

Assignments > Device

Step 5.

O New Project Wizard

EDA Tool Settings

Specify the other EDA tools used with the Quartus Prime software to develop your project.

EDA tools:
Tool Type Tool Name Format(s) Run Tool Automatically
Design Entry/Synth... v<NOne> ~ ‘ <None> R Run this tool automatically to synthesize the current design
Simulation ModelSim-Altera ¥  Verilog HDL v [J Run gate-level simulation automatically after compilation
Board-Level Timing <None> v |
Symbol <None> v
Signal Integrity v <None> v
Boundary Scan ' <None> v
< Back Next > Finish Cancel Help

To modify the EDA Setting use:
Assignments > Settings

\
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Step 6.

O New Project Wizard

Summary

Project directory:
Project name:
Top-level design entity:
Number of files added:
Number of user libraries added:
Device assignments:
Design template:
Family name:
Device:
Board:
EDA tools:
Design entry/synthesis:
Simulation:
Timing analysis:
Operating conditions:
VCCINT voltage:

Junction temperature range:

When you click Finish, the project will be created with the following settings:

Z:\Users\talarico\VTut
Vtut

light

2

0

n/a
Cyclone IV E
EP4CE115F29C7

n/a

<None> (<None>)
ModelSim-Altera (Verilog HDL)
0

1.2v

0-85°C

< Back Next > | Finish |“ Cancel

\
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Q Quartus Prime Lite Edition - Z:/Users/talarico/VTut/VTut - light - a X

File Edit View Project Assignments Processing Tools Window Help .
OFE4A IR 2cm 1 /SEQTr+%$.9040E 9
Project Navigator ‘ A\ Hierarchy "Q R8 x IIP Catalog Re x
Entity:Instance CULLABURE. DES| N l HA |.~ X =
4% Cyclone IV E: EPACE115F29C7 Intel’ Qualius ime} Y v o Installed 1P
E® jight 7 S 1. s ¥ Project Directory

Find Out How

No Selection Available

v Library

Basic Functions

DSP

Interface Protocols

Memory Interfaces and Controllers
Processors and Peripherals

University Program

O v v v v v

Tasks Compilation v=R8 x @ search for Partner IP
Task Time
¢ v P Compile Design
> P> Analysis & Synthesis
> P Fitter (Place & Route)
v > P> Assembler (Generate programming files)
v > P> TimeQuest Timing Analysis
v > P> EDA Netlist Writer
W Edit settings
) Program Device (Open Programmer)
+ Add.

al (@4 [A] [ <sFitter> | 88 Find.. | |88 Find Next|

Type ID  Message

I||-i=@x|

[Messages

System  Processing

0% 00:00:00

3. Files and Directories up to this point

$ 1s -1p
VTut.gpf

db/
incremental_db/
light.cvs
light.gsf
light.v
light_nativelink_simulation.rpt
light_tb.v
output_files/
simulation/

$ cat VTut.qpf / Quartus project file

QUARTUS_VERSION ="17.0"

DATE ="14:01:19 August 15,2017"
# Revisions

PROJECT_REVISION = "light"

$ cat light.qgsf /

set_global_assignment -name FAMILY "Cyclone IV E"

set_global_assignment -name DEVICE EPACE115F29C7

set_global_assignment -name TOP_LEVEL_ENTITY light

set_global_assignment -name ORIGINAL_QUARTUS_VERSION 17.0.2

set_global_assignment -name PROJECT_CREATION_TIME_DATE "14:01:19 AUGUST 15, 2017"
set_global_assignment -name LAST_QUARTUS_VERSION "17.0.2 Lite Edition"

Quartus settings file
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set_global_assignment -name VERILOG_FILE light_tb.v

set_global_assignment -name VERILOG_FILE light.v

set_global_assignment -name PROJECT_OUTPUT_DIRECTORY output_files
set_global_assignment -name MIN_CORE_JUNCTION_TEMP 0
set_global_assignment -name MAX_CORE_JUNCTION_TEMP 85
set_global_assignment -name ERROR_CHECK_FREQUENCY_DIVISOR 1
set_global_assignment -name NOMINAL_CORE_SUPPLY_VOLTAGE 1.2V
set_global_assignment -name EDA_SIMULATION_TOOL "ModelSim-Altera (Verilog)"
set_global_assignment -name EDA_TIME_SCALE "1 ps" -section_id eda_simulation
set_global_assignment -name EDA_OUTPUT_DATA_FORMAT "VERILOG HDL" -section_id eda_simulation
eda_simulation

4. Start Compiling the Design Check syntax &
Processing > Analyze Current File > Start > Analysis & Elaboration / translate HDL into

eneric Boolean
Make sure to verify all Info/Warnings/Errors & .
equations

Tools > Netlist Viewers > RTL viewer

@ RTL Viewer - Z:/Users/talarico/VTut/VTut - light . O X

File Edit View Tools Window Help

Search altera.com I.

‘T“T* Oh #m k jSwkl E:..:OL.:\: > Page::1of1 "
’ Netlist Navigator pa x [Q light:1

> Bt light

f~0

X1 >— f~2

f~1

100% 00:00:05
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Synthesize HDL into

Processing > Analyze Current File > Start > Analysis & Synthesis & target Technology

Tools > Netlist Viewers > Technology Map Viewer (Post Mapping)

File

Edit View Tools Window Help

e [Ce=[= 08

&

H Technology Map Viewer - Post-Mapping - Z:/Users/talarico/VTut/VTut - light . O X

|Search altera.com |.

QI IWrEPORRAL -l -

Netlist Navigator

R x

> E= light

IQ light:1

x1~inpu f~output
DATAC  COMBOU \ s
10_IBUF [DATAC | 10_OBUF
x2~input LOGIC_CELL_COMB

[

10_IBUF

100%  00:00:04 .
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4. Pin Assignments

More often than not, the Pin Planner has issues loading automatically the pinout assignments saved in

light.csv. Put the assignments in a text file light.txt and load it manually using:

Assignments > Import Assignments (file name light.txt)

$ cat light.txt
# Pin Assignments

To, Direction, Location
x1, input, PIN_AB28
x2, input, PIN_AC28

f, output, PIN_E21

& Pin Planner - Z:/Users/talarico/VTut/Vtut - light
File Edit View Processing Tools Window Help
Report 28 x Top View - Wire Bond Pin Legend
Foa Cyclone IV E- EPACET1 5F29CT
M| Report notavailable . Symbol Pin Type A
01ssiiasd .
fotoviNololoriNoJo} ooo folols (
. goo ooogo ooo 500 . ) Userl/o
- Q80056000005 500O00! P
B § gggs§§§ g —
Q [geseouesYeegue 08 @  Fiterassigned.
ARRaEe e = ®  unbondetpus
= OOCOAVOD, AV A OOXI 0000 Unbon pa
Q00OABOQ BOOO0000 ™Y "
§ 08RG0 SOXOXONRRG200 Reserved pin
ji : 8 8 © Other configura...
b ontoe © omvoe
Groups  Report 5980AYC0 Y, OOVAS000 ® DEV_CLR
B dis
Tasks a8 x OAOOOO0OAORKOOLODOA0 joler 1 n DIFF_n
SRR -
v I~ Early Pin Planning ~ goooooo0 888 e DIFF_p
i W caynpimng. 'oi%ﬁﬁﬁﬁ&%°%ﬁ° @ oo
s < > & bpas v
=y= | * [Named* v [«»| Edit | X Filter: Pins: all v
m-| s
IEI 2 Node Name Direction Location 1/0 Bank VREF Group 1/0 Standard Reserved  CumentStrength  Slew Rate Differential Pair  strict Preservatior
£ Output PIN_E21 7 B7_NO 2.5V (default) 8mA (defaul) 2 (default)
H » x1 Input PIN_AB28 5 B5_N1 2.5V (default) 8mA (default)
» X2 Input PIN_AC28 5 B5_N2 2.5V (default) 8mA (default)
= <<new node>>
=
an
"Pa| 2
anen | &
v | =
0%  00:00:00

On the DE2-115 board, the input PIN_AB28 is physically mapped with the switch SW[0]
On the DE2-115 board, the input PIN_AC28 is physically mapped with the switch SW[1]
On the DE2-115 board, the output PIN_E21 in mapped with the green light emitting diode LEDGI[O0]
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6. Continue Compiling the Design

Place & Route
Processing > Start > Start Fitter &7

Tools > Netlist Viewers > Technology Map Viewer (Post Fitting)

A Technology Map Viewer - Post-Fitting - Z:/Users/talarico/VTut/VTut - light

File Edit View Tools Window Help

“““““ Netlist Navigator H e x ’m light:1 Iil

O

X

ISearch altera.com

|®

o Cle(=00 R QITWNEDOGRAL > mln -

, > E= light

~ALTERA_ASDO_DATA1-
~ALTERA_DATAO-
ALTERA_FLASH r(CE_nCS0~

121

~ALTERA_ASDO DATA1-—ibast

10_1BUF
~ALTERA DATAO-—ibnst

10_1BUF
~ALTERA_FLASH rCE nCSO—ibust

0 _18UF
X1-rgen

0_18UF
2o

0_18UF

-Ah'l:w CEQ-—ctnst

10_OBUF (OPEN DRAIN)
-Ah?& DOLK-—obut

10_0BUF

10_0BUF

~ALTERA rCEQ-

~ALTERA_DCLK~

0% 00:00:00
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7. Simulation
Step 1.

Start Modelsim. The path to the executable should be located to something similar to:
C:/intelFPGA_lite/17.0/modelsim_ase/win32aloem/

For convenience create a shortcut to it:

L1

M

modelsim -
Shortcut

Step 2.

File > New > Project
Project name: VTutSim
Project Location: Z:/Users/talarico/ VTut/simulation/modelsim

M Create Project X

— Project Name
[VTutSim

—Project Location
ltalaricor’VIut/simlation[modE 1sim Browse...

—Default Library Name
lwork

—Copy Settings From
lion[modelsim/modelsim. ini Browse...
% Copy Library Mappings { Reference Library Mappings

OS Cancel
N\

M Add items to the Project X

—Click on the icon to add items of that type:

Create New File Add Existing File
Create Simulation Create New Folder

Close
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Alternatively,

1) ignore the popup window (i.e., hit close),

2) switch from the Library Tab to the Project Tab and
3) select:

Project > Add to project > Existing File:
Z/Users/talarico/VTut/light.vhd
Z:/Users/talarico/VTut/light_tb.vhd

™ ModelSim - INTEL FPGA STARTER EDITION 10.5b - a X
File Edit View Compile Simulate Add Project Tools Layout Bookmarks Window Help
2| = QB ta 11424 oimne o
Execute
New File... e ﬂ §j’ﬂ
Remove from Project Existing File... P ———
SHSTTETIEEES  Update Simulation Configuration. .. Objects e H 4 l”
StatusType |OrdeiMg Folder... Name Value |Kind  |Mode I 5
|¢ Processes (Active) Roxa + l”
¥ [Name Order |Parent Path Class Info
KIENS | | »
f-} Transcript i + & x|
# Errors: 0, Warnings: 0 ;I
#
# Loading project VIutSim
[ModelSim > -
[ |Project : VTutSim | <No Design Loaded> [<No Context> P

If the files are not ready and you need to create them from scratch use:
Project > Add to project > New File.

Step 3.
Compile > compile all
Step 4.

In case you do not see the two compiled files under the work library, remove the work library. The
work library will be regenerated with the correct info!
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Simulate > Start Simulation
+ work

+ light

+ light_tb

ﬁ Start Simulation

Design ] VHDL ] Verilog ] Libraries ] SDF ] Others ]

4

TIName |Type |Path
=] work Library Z: Users/talarico /NTut/simulation/mod...
1 light Module Z:Users/talaricoNTutflight.v
1 light_tb Module Z: [Users/talarico/NTutflight_tb.v
, _+_'|—‘1 220model Library SMODEL_TECH/.. faltera/vhdl/220model
, ﬂ—ﬂ 220model_ver Library SMODEL_TECH/.. faltera/fverilog/220m...
, :hll altera Library SMODEL_TECHY/. . faltera/vhdl/altera
1}—'}_ altera_lnsim Library SMODEL_TECHY/.. faltera/vhdl/altera_|...
ﬂ—m altera_Insim_ver Library SMODEL_TECH/.. faltera/verilog/altera...
, _+_'|—m altera_mf Library SMODEL_TECH/.. faltera/vhdlfaltera_mf
+lil altera_mf_ver Library SMODEL_TECH/.. faltera/verilog/altera...

Resolution

E
2l

Design Unit(s)
|7|work. light_tb

|

|default

i

S, ..... ak...acanml

vsim > view wave
vsim > add wave sim: /light_tb/*
vsim > run —all
The simulation runs forever!!!
To stop the simulation, you can use:

Simulate > break

N
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A better approach is to automatically stop the simulation by using a $stop statement in the testbench
code.

A few other useful commands to remember are:

vsim > restart —force
vsim > run —all

vsim > wave zoomout
vsim > wave zoomfull

8. Finish Compiling the Design

Processing > Start > Assembler € Generating Programming files
(light.sof and light.jdi)

sof = SRAM object file
jdi = JTAG Debugging Information

9. View Reports

Make sure to read carefully the reports generated at each step of the design process.
The reports can be accessed through the Quartus’ workspace window or directly in the output_files
folder.
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10. Programming and Configuring the FPGA

Before Programming the FPGA make sure to set the board in RUN mode (JTAG mode).

Tools > Programmer

Edit > Add File (Z:/Users/talarico/VTut/output_files/light.sof)

The hardware Setup must be USB-Blaster [USB-0]

-
A Programmer - [ChainL.cdf]*
File  Edit  ‘iew

o

rocessing  Tools — Window  Help &)

=]

(===

L Change File...

Search altera.com @
f‘ Hardware Setup...| USB-Blaster [USB-0] Mode: |ITAG N Progress: 100% (Successfm

[7] Enable real-time ISP to allow background programming (for MAX 1T and MAX ¥ devices)

W File Device Checksum Usercode Programj Verify Blank- Examine Security  Erase ISP
Configure Check Bit CLAMP

e C:Users/talaricojDesktopflight.sof  EP4CE115F29 00S62EF6 00562EF6

,ﬂ Auto Detect
{ Delete

n

| gﬂ Save File

Tup

1% Down

EP4CE115F29

TDO

-~
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11. Testing the Circuit on the Development Board

| USB Blaster port

Power
supply

Power
on/off
button

RUN

PROG

I e @

SwW17

SW1 SWo

KEY3

KEYO
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